• Hello everyone,

    We're happy to announce that our forum is back online! We needed to take some time off to discuss and decide on how to handle sensitive topics in our community.

    The team has posted an in-depth comment regarding a recent incident and our stance on politics and sexuality in our forum. We also added a dedicated paragraph about this in the forum guidelines. This is part of our commitment to maintain a welcoming and inclusive environment for all our users. Your understanding and continued support in building a creative and respectful community are highly appreciated.

    Thank you, the CX Dev-Team

Any Xcode pro here?


Well-known member
3rd Party Module Dev
Tutorial Author
Jan 2, 2020
The update of new Xcode was so slow so I decided to download it from their Apple's development website as an xIf file instead.
Bad idea.. After replacing xcode in applications with the unpacked xif file and after deleting the appropriate preference file in library/.. it does not open.

So of course I decided to do the proper thing and put it overnight to update, and now after 20h 8Gb was downloaded.
But it is still the same? Is there any solution for this? Do I really have to reinstall macOS? Everything else is updated btw and in good order.

Xcode *does* start but this menu is all that it shows (look at the bottom). There's no Main windows available?

Solved it!

If anyone is having the same problem at some point just open the terminal and write into it :
defaults delete com.apple.dt.Xcode

That will fix it.
Top Bottom