Crazy for sound [SOLVED]

Jimmy

Active member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
715
I know for sure that Cerberus-X uses the Audio API perfectly and covers all the modern browsers Safari, Chrome etc. It just works.
Web-Audio API is finicky but Cerberus works everywhere (as long as you've updated your browser to some degree).

But today I tried some code that I know for sure works and HTML5 sound have stopped working? I tried all the CX versions this year, some which I know works and none works now.

So my thoughts starts to wander;
Of course the first thing that comes to minds is ; maybe the browsers have changed their local security file access?
I wish I had some html examples that play samples from local files but I don't have that right now.

* I use Safari and Chrome is the same I use all the time and they used to work great with wav files.
(my macOS is not updated to BigSur because it is too small for an update the hard-drive cannot fit another update ever but maybe Apple sent a micro-update, I do not know). Safari and Chrome of course could have been updated without my knowledge that they did this big change.

I immediately go to try the live audio-examples on this site and they work perfectly.
(Btw for a long time I haven't been able to compile the included audio examples into working HTML5 for myself but I didn't say anything because I thought it was just me and some format issue and my own simple examples *did* work and that was more than enough for me.)

But now when no audio code at all works in HTML5 any longer I have to ask; Does anyone else have the same problem?

Can you compile to HTML5 platform and get sound?

I don't know what it can be..
 
Last edited:

Jimmy

Active member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
715
Solved!

For Chrome you need to click in a canvas before you are allowed to use sound. This is a general security feature not tied to Cerberus-X.

For Safari you need to do this now on the new macOS/Safari :
Go to settings, Auto-play and change to Allow All Auto-play.

This is good to know. It might work with Windows & Linux as well I do not know.
But for new macOS this is true.

Sound works in both browsers :)

Screenshot 2020-11-20 at 04.24.45.png
 
Top Bottom