• Hello everyone,

    We're happy to announce that our forum is back online! We needed to take some time off to discuss and decide on how to handle sensitive topics in our community.

    The team has posted an in-depth comment regarding a recent incident and our stance on politics and sexuality in our forum. We also added a dedicated paragraph about this in the forum guidelines. This is part of our commitment to maintain a welcoming and inclusive environment for all our users. Your understanding and continued support in building a creative and respectful community are highly appreciated.

    Thank you, the CX Dev-Team

Implemented cserver


Well-known member
3rd Party Module Dev
Tutorial Author
Jul 31, 2017
Hi there

I made a custom version of cserver (I call this version 18.01.12). It is slighty faster than the one that came with the last cerberus download...

Have a look! :)


  • cserver.cxs-20180112.zip
    4.3 KB · Views: 250
  • cserver_winnt.exe-20180112.zip
    402.5 KB · Views: 279
Version 18.01.17 is up.
- now also works when minimized
- CPU usage got cut down again
- speed on the other hand increased (cserver now responds ultra fast to browser requests)


  • cserver.cxs-20180117.zip
    5 KB · Views: 264
  • cserver_winnt.exe-20180117.zip
    403.6 KB · Views: 276
Version 18.03.05 is up.
- removed this thing called "cludge fix for ted", because the problem this fix should have prevented couldn't be reproduced anymore.

Also, the executable zip now contains a data folder, containing the mojofont, so the cserver won't be just black screen anymore ;-)


  • cserver.cxs-20180305.zip
    5 KB · Views: 258
  • cserver_winnt.exe-20180305.zip
    442.8 KB · Views: 274
Is this specific to something or should I get this file?
It's not specific. Well, the exe is specific to Windows ;-) but the cserver.cxs is meant to be an update for the default cserver.cxs (version 17.7.3) which was a replacement for cserver.bmx. Version 18.03.05 is noticeable faster than 17.7.3 and uses less cpu.
Is this tested on all desktop platforms?
I only tested it on Windows 7 / 10, due to lack of Mac / Linux
Version 20180305 is now on GitHub.
Just tried it and starting speed is back to normal. The lag the other version had was just annoying.
I am using Jungle, so I am not sure where this behavior comes from: When I run a program, it starts normal, but when I start the same program without closing cserver it won't start. Running in chrome on Win10
when I start the same program without closing cserver
by this, do you mean you chose just "Build..." or "Build and Run..."?

When you only build, you just have to reload your CerberusGame-Tab in Chrome.
When you build and run, I can't explain why Chrome shouldn't load it...

I'm using Opera and it works both on Win7 and Win10.
in Ted it works... so it is a JungleIde thing.
I get this error log:

Sending Kill signal...
Error killing process <unknown>. Process has exited, so the requested information is not available.
Connection properly closed.

So maybe Jungle is not allowing another start, if it cannot kill the former connection successfully!?
But it starts all the earlier tries later, when you close cserver.
OK I'll look into that. There's this odd behaviour, that after the first time I hit "Build and Run..." the "Cancel Build" button is active, because - I guess - the Server is still running and the IDE thinks the compilation process hasn't finished yet. Happens in Mollusk and Ted for me, but didn't really bug me. Maybe JungleIDE can't really handle that but I can't blame the IDE because ACTUALLY, transcc should start cserver like "detached", so its execution would continue, and then quit properly... But if this doesn't happen, it's probably a cserver thing =/
Nah, mixed up something in my last post:

transcc starts cserver, which -if necessary- starts cserver detached acting as server, then opens the url and quits, leading transcc to quit too. In my opinion exactly as it should. At least when running it from cmd. Because weirdly, Mollusk seems not to get that and still shows the "Cancel Build" button as active o_O
thanks for looking into that. It doesn't bother me to much. Compile /start time was definitely an issue for me, so great job!
Thanks! And no worries, I looked into it to make sure (as good as possible) not to let faulty software into the wild ;-)
@Holzchopf did you test your cserver with OGG sound files? Somehow one of my games is not loading them and cserver reports problems regarding OGG sound files.
I did not*. What kind of problems does cserver report and how? And when you write "one of my games" does this mean the problem only occurs for that specific one of your games?

* in the mean time I did. Can you check if example examples\mojo\mak\audiotest\audiotest.cxs works for you please? Works fine here.
I noticed it there, didn't check more. But will do so. I am at work atm so this will have to wait till tonight.
Oh and one mandatory question when it comes to HTML5 games: What browser do you use?
Ok, that oog problem was my code. Sorry about that. But I discovered that Cserver doesn't like to be closed. After that it doesn't open or when it opens, it states that "CServer failed". So far I need to restart TED to get it working again... most of the time.
Top Bottom