How to use DebugStop?

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,187
When I try use DebugStop (compiling using Desktop mode, and debugmode on) I put the command in OnRender as the first instruction, which makes it lock up everything and I had to reboot? After trying this I have to confess that I have not had time yet to try to put the instruction elsewhere in the code bc I was so sure it would work in some way or another. Will try more later on..

Am I supposed to use it in OnUpdate or other special places in the code? Can I use it in methods and functions called by OnRender?
 

MikeHart

Administrator
3rd Party Module Dev
3rd Party Target Dev
3rd Party Tool Dev
Joined
Jun 19, 2017
Messages
3,345
Works fine here. Can step through the rendering with a problem in mojo. Windows 11.
 

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,187
Well I tried on a demo again now, I picked a standard Mojo2 demo because that is what I use. I added DebugStop command inside OnRender because I don't have more specific instructions on how to use the debugger in Cerberus.

I then select Desktop and Debugmode. It freezes.

What am I doing wrong?

Screenshot 2022-07-07 at 19.02.25.png
 

MikeHart

Administrator
3rd Party Module Dev
3rd Party Target Dev
3rd Party Tool Dev
Joined
Jun 19, 2017
Messages
3,345
Tried Mojo2 example , works fine as well.

Which platform are you building on?
 

MikeHart

Administrator
3rd Party Module Dev
3rd Party Target Dev
3rd Party Tool Dev
Joined
Jun 19, 2017
Messages
3,345
Mac I guess. Which OS version? Your console in the screenshot looks like you are not even building the app, never mind executing it.
 

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,187
Okay you mention the screenshot. Yes that is correct I had to reboot the mac bc it compiles of course, I made the screenshot to show the code insert, post. When I was running the app It gave you a buzy circle that locks you from tabbing. You need a hw restart. Nothing seems to be wrong otherwise.
 

MikeHart

Administrator
3rd Party Module Dev
3rd Party Target Dev
3rd Party Tool Dev
Joined
Jun 19, 2017
Messages
3,345
As you didn't mention the OS version of MacOs, I went ahead and tested it on 12.2.1. Guess what? It worked just fine.
Now I am updating my good ol' mac mini and will report back again.
 

MikeHart

Administrator
3rd Party Module Dev
3rd Party Target Dev
3rd Party Tool Dev
Joined
Jun 19, 2017
Messages
3,345
After reinstalling XCode 13.3.1 and updating to Monterey 12.4.1, debugging on Desktop still works as intended and even in the OnRender and mojo2.
 
Top Bottom