Mac OS Big Sur and Apple M1 chip.

ddabrahim

Active member
Tutorial Author
Joined
May 3, 2020
Messages
148
Well, every app, not only CX apps take forever to start on the simulator. At least on my machine.
Yes especially the first time, it could take some time to start the simulator and launch the app in the simulator I have also experienced this on my 2019 iMac but the black screen was new, if I'm lucky the black screen I was getting with Cerberus is also the result of this slow loading of the app or something. I thought it is because of OpenGL, never bothered to try again and maybe wait a bit longer. :rolleyes:
 

APC

New member
Joined
Aug 8, 2017
Messages
45
Mike I was able to install Big Sur on my Mac Book Pro
Cerberus runs fine.
When I was testing the compatibility of iOS app running on Mac I compiled XCode with the , iPhone, iPad and Mac and I got these errors:
(NOTE: If I remove the Mac from the Deployment Info it compiles with no errors)

1- Lexical or Preprocessor Issue
OpenGLES/EAGL.h file not found
main.h
In file included from /Users/username/Documents/_Cerberus/Defender1/Defender1.buildv2020-05-09/ios/main.mm:2:

2- Lexical or Preprocessor Issue
OpenGLES is deprecated and is not available when building for Mac Catalyst.
Consider Migrating to Metal instead, or use "#if !TARGET_OS_MACCATALYST" to conditionally import this framework,
first importing TargetConditionals.h if necessary. main.h
 

MikeHart

Administrator
Joined
Jun 19, 2017
Messages
2,815
Are you still using 2020-05-09? Cause your build folder suggest that you do.
 
Top Bottom