Pre-built binaries?

The latest has a Windows binary
Is there a pre-built binary for Linux these days?
Be warned that some Ubutu 2022.04+ derived distributions have issues with linking QWebEngineView, so there will be no built in help.
Be warned that some Ubutu 2022.04+ derived distributions have issues with linking QWebEngineView, so there will be no built in help.
OK thanks, I'm on MX Linux, Debian based so maybe not an issue...hopefully!
OK, resorted to building for Linux, all went well and help is accessible. However, when I try to build/run an example program fro HTML5 target I get:

/cerberus-2022-03-26/bin/cserver_linux: not found

and there's no such file in that directory. Any suggestions please?
You have installed all the required dependencies?
See here

Make sure that there is no directory still in the cserver source directory.
You have installed all the required dependencies?
See here
I thought I had... turns out 'libxxf86vm-dev' was on a new line in that forum thread and hidden by my terminal window's title bar!! Installed and rebuilt and both HTML5 and Desktop targets are compiling properly now. Thanks very much (y)
Thanks Paul. Overworked but I am ok. Hope you too. Long time no see
I will see when the last Linux release was and will upload that as well
You will find the linux release there as well now. The last MacOs release (2021-05-16) is under that release.
Hi Mike, can you build an updated version for MacOs? I tried building it, and it apparently succeeded, but it doesn't seem to buid everything and it doesn't run.
I could try maybe next weekend but maybe your version of MacOS will stop it from running as it comes from an uncertified entity.
Any error messages you got? You do have Xcode installed? Which example did build but did not run?
I'm building on a Macbook Air M1. I've attached the log, many warnings, but it seems to build executables. But they won't execute. I assume something to do with code signing or latest OS. I haven't got a clue, it's very different to previous versions of MacOS.


  • cerberus_build.txt
    297.8 KB · Views: 26
The text file stops when it is about ot build TED. Did you install QT5 ?
I don't have a M1 machine. Will ask Martin if he knows something. He uses a M1 machine at our company and Cx all the time.
I think I posted something before on the #if TARGET_OS_IPHONE warning. Those are in modules/cerberus/native/lang,cpp
They should I believe be #ifdef TARGET_OS_IPHONE. As TARGET_OS_IPHONE is not defined, it will evaluate to zero and not be added as part of the build.

Those depreciated calls to sprintf should probably be looked at just in case Apple have decide to do something about them later.

The changing vfork to plain old fork should still work. vfork was faster than fork, because vfork just used the same memory space as the parent process, while fork copied it's parent process stack.

The launcher 'MACOSX_DEPLOYMENT_TARGET' looks like it needs updating.

warning: invalid character in Bundle Identifier. This string must be a uniform type identifier (UTI) that contains only alphanumeric (A-Z,a-z,0-9), hyphen (-), and period (.) characters. (in target 'Cerberus' from project 'Cerberus')
/Users/psagor/Downloads/cerberus-2022-03-26/src/launcher/xcode/Cerberus.xcodeproj: warning: User-supplied CFBundleIdentifier value 'com.whiteskygames.cserver_macos' in the Info.plist must be the same as the PRODUCT_BUNDLE_IDENTIFIER build setting value 'com.krautapps.cerberus-launcher'. (in target 'Cerberus' from project 'Cerberus')
That bit is probably cause by using "default" to modify the info.plist in the build script. That line needs to be commented out and the launcher built with something like:
xcodebuild "PRODUCT_BUNDLE_IDENTIFIER=com.whiteskygames.launcher" -scheme Cerberus -configuration release -project $SRC/launcher/xcode/Cerberus.xcodeproj -derivedDataPath $SRC/launcher/
The xcode project may also need updating to sort out the PRODUCT_BUNDLE_IDENTIFIER issue.

What would be more of a worry are those bits issuing warnings about the garbage collector. I've seen some strange behaviour on Linux with using DataBuffers lately.

As I'm stuck using an old iMac. I wouldn't be able to do much in fixing any issues related to a more modern Mac.
Over the last week. I've been doing a bit reworking of the build scripts and some work on Ted over the last few months. The scripts should build the current tools. Just use git to clone the repository with:
git clone -b experimental

Set the execute permission on the script and run script passing the -m option. It will display a menu where you can build each path of Cerberus individually.
Last edited:
I tried download the above, but it wants a username and password. Mine doesn't work.
Top Bottom