Touch input

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,229
I wonder if anyone still care about older mobile. I got the changce to try my project on Android 4.4 today.
It actually works fine. BUT, touch is delayed like the first 10 seconds.
I'm was trying to share my experience is hard as the code belongs to my clients, to create an example to show this will need continoal access to the hardware and some time. If i can have that I will do some testing.

But until then, what about the touch delay, any ideas what can cause it?

It disappears around Androdi 5 6 or 7. I don't have all the hardware versions to try on so I can only narrow it own so much.

Everything else works and animates from the start! so it cant be loading media. It's very odd.
 

SLotman

Active member
3rd Party Module Dev
Tutorial Author
Joined
Jul 3, 2017
Messages
223
Can't say that I had this problem before. Are you using mojo2? If so, does it goes away when using 'plain' mojo?

Can you provide a simple example that reproduces the problem? I *do* have an android 4 tablet here :)
 

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,229
I went through the examples that follows CX I had to choose a Mojo2 that had touch of course. I found one called bumpytest.cxs and it was.. not find but not the same result i got with my code either. Instead of starting fast with disabled touch it lets you waait for pretty the same amount of time, which is 5 sec. 5 sec black screen and when it starts it fives you immediteability to use the touch.

So it's the same amount of time (3-9sec) but it won't even show anything wheres mine shows everything but wont let you touch the screen.

After that I wanted to check Mojo1 examples, they worked fine., also it work really good on Android versions, not perfect but always better up till version Android 7.1. After that there is no point in using Mojo1 at all. So touch was immeidalty available in mojo2 examples. But, it lets you wait with a black screen instead. The fact that it is the same amount of time makes me think.

I don't have any ideas about what causes this as nether of these codes has strangess in them. It's just a fact I guess. Don't use too old Android. But I use other tools I can skip that problem altogether so if this was superimportant I would look inside CX sourcecode bc you can't anything on the surface.

Luckily I don't need to use older I suggested an update of Android haha. Problem fixed!
 

Wingnut

Well-known member
3rd Party Module Dev
Tutorial Author
Joined
Jan 2, 2020
Messages
1,229
I got another codebase running without any issue at all so maybe I can compare everything to figure out but. I don't load any media or anything in this example, is it that easy? Maybe.. I could somehow make that dissapear using only code maybe i used directives and how update works.. That's all I can come up with myself.
 
Top Bottom