Cerberus X v2018-03-02 released

magic

Active Member
3rd Party Module Dev
3rd Party Tool Dev
Joined
Mar 5, 2018
on my fast test:

Ted.app - can open but
~ Help docs not found. So app ask to rebuild. But when I reply yes nothing happen for a long time.
~ Then I goto setting and found out tool path for Cerberus is empty. After I give it path, I can rebuild docs
~ On setting, UI Theme is empty. Cannot choose any.
~ Build target empty.
~ When restart Ted, app ask again for docs not found? Probably path problem
Cerberus.app - cannot open.
~ The glim of Ted icon appear for a second and then gone.
 

magic

Active Member
3rd Party Module Dev
3rd Party Tool Dev
Joined
Mar 5, 2018
Is there a themes folder inside your Cerberus/bin folder?
Yes. many of them

About Cerbrus.app:
I already give permission to both main app and ted but only ted can be open.
On Cerbrus.app, look like its try to open but fail. I can see icon on my tray for about one second then disappear.

Sounds a lot like a permission problem. Like we had them with basically all CX releases.
When we develop app, we want people to try use it but OS like Mac and Windows make it difficult :/
For an indie developer like us, its a frustration. Anti-virus another story...
 

MikeHart

Administrator
Joined
Jun 19, 2017
Location
Germany
Yes. many of them

About Cerbrus.app:
I already give permission to both main app and ted but only ted can be open.
On Cerbrus.app, look like its try to open but fail. I can see icon on my tray for about one second then disappear.


When we develop app, we want people to try use it but OS like Mac and Windows make it difficult :/
For an indie developer like us, its a frustration. Anti-virus another story...
Sorry for the inconvenience. I am surprised that Launcher isn't starting. Anyway, I will change TED so it stores the settings in different folders, not the app location anymore. This should get rid of the permission problems you see when it tries to store its settings.
Same goes for the created html files.
 

magic

Active Member
3rd Party Module Dev
3rd Party Tool Dev
Joined
Mar 5, 2018
Sorry for the inconvenience
Not really a problem @Mike. At the moment I'm using v2017-10-24 with Mollusk IDE.

I will change TED so it stores the settings in different folders, not the app location anymore. This should get rid of the permission problems you see when it tries to store its settings.
Same goes for the created html files.
Version 2017-10-24 of CX working great. Both Ted and Main app work. I can say its 99% same as the PC version.
Maybe the bug is only on path setting.
 
Top Bottom