Cerberus X v2019-05-05 Ted Crashing (Linux)

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
In 'Options', change the font size and click ok then re-open 'Options', click to open the 'Font Family' drop-down = crash.

I can build and run projects ok otherwise but after this crash the last opened source file isn't remembered, there's nothing in 'recent files' and the target is set to C++ tool.

EDIT: noticed the version in Ted's window title bar is 4th May, not sure if that's relevant...

Linux Mint 64 bit.
 
Last edited:

rickychus

New Member
Joined
Sep 26, 2017
Hello,
I have Bliztmax installed on Lubuntu 32bits runs fine. I installed a pack of 700 fonts that I use very frequently (folder ".fonts"). The Blitzmax IDE crashes when starting, not when I remove the folder, I guess it is when loading the fonts, some must not be compatible with the IDE or there may be some damaged...
It will be a coincidence?
 
Last edited:

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
Did the last version had the same problem?
Nope :(

EDIT: Correction - YES! Clearly I just never noticed if before.

It only happens if I try to change the font in the same session - if I change the size then quit and restart I can change the font face or size without issue.
 

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
Hello,
I have Bliztmax installed on Lubuntu 32bits runs fine. I installed a pack of 700 fonts that I use very frequently (folder ".fonts"). The Blitzmax IDE crashes when starting, not when I remove the folder, I guess it is when loading the fonts, some must not be compatible with the IDE or there may be some damaged...
It will be a coincidence?
You mean Cerberus not Blitzmax?
 

rickychus

New Member
Joined
Sep 26, 2017
You mean Cerberus not Blitzmax?
With Blitzmax that happened to me, with Cerberus I did not try it because I deleted the extra Fonts that I added ...
Maybe the problem is the same. Have you placed more fonts than the default ones that Linux brings?
 

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
With Blitzmax that happened to me, with Cerberus I did not try it because I deleted the extra Fonts that I added ...
Maybe the problem is the same. Have you placed more fonts than the default ones that Linux brings?
Yes I have a few others installed but I don't think that's the issue.
 

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
Hmmm. I've tried selecting different fonts, changing the font size and clicking ok then going back to selecting a font and it seems to happen every time. What's the default font with ted?
 

rickychus

New Member
Joined
Sep 26, 2017
In my case (Linux Lubuntu 32 bits) is "DejaVu Sans Mono".

Yes I have a few others installed but I don't think that's the issue.
Later, I will try to install the 700 fonts again and test if Cerverus (TED) gives a problem. I tell you how to get that test.
 

dawlane

Active Member
CX Code Contributor
Joined
Jun 21, 2017
What's the default font with ted?
If I remember the default font should be taken from what ever the system defines as it's default mono spaced font. On Linux there is no default font.
 

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
If I remember the default font should be taken from what ever the system defines as it's default mono spaced font. On Linux there is no default font.
I can't seem to pinpoint what is causing the crash, it happens whichever font I use and i'm not using any weird fonts just deja vu, liberation, ubuntu etc.
 

rickychus

New Member
Joined
Sep 26, 2017
Hello,
I installed the 700 font again:
Blitzmax IDE does not load.
CerberusX IDE works fine, but the options menu appears much wider than normal, but I can not make the error happen as Paul59 describes it.
Have you tried to start CerberusX from a terminal (CTRL + ALT + T) and see if it gives an error message by console?
I can not think of anything else, except to make a clean installation of Linux... :(
 
Last edited:

MikeHart

Administrator
Staff member
Joined
Jun 19, 2017
Location
Germany
Yes, having a look at the console window is a good suggestion. I can create a debug version tonight when i am back from work, which might print out more information at the crash.
Gosh i love it when things work for most but not for one or a few.
 

Paul59

Active Member
Joined
Dec 13, 2018
Location
UK
Starting from a terminal I still get the crash but there's no output to indicate the cause :(
 

rickychus

New Member
Joined
Sep 26, 2017
Starting from a terminal I still get the crash but there's no output to indicate the cause :(
Wait for Mike to give you a special version of the IDE with debugging messages. You will know what is the cause of your problem.
 

MikeHart

Administrator
Staff member
Joined
Jun 19, 2017
Location
Germany
@Paul59 sorry for not providing a debug build. I ran into some health issues last night. I will provide you one soon.
 

rickychus

New Member
Joined
Sep 26, 2017
I hope you're better Mike, and that it's just something mild ...
There is nothing better for the ills than a good rest, accompanied with a tasty hot soup and a good drink of wisky ^^
 
Top Bottom