Cerberus X v2019-05-05 Ted Crashing (Linux)

rickychus

Member
Joined
Sep 26, 2017
No rush, it's not like I'm changing the editor font settings every 5 minutes! :D
humm, Good point, maybe the shots come out that side.
Mike, could you restrict the use/load of the Fonts in the IDE to avoid problems between OS? I mean, leave five-six clear reading Fonts that are native/incorporated in TED/Hades. Assuming the problem is the loading of fonts...

(joke) It is for those who, when they get bored, do not have many opportunities to change the sizes or types of rare fonts for code :D(joke)
 
Last edited:

MikeHart

Administrator
Staff member
Joined
Jun 19, 2017
Location
Germany
Ok, here is a version of Ted compiled in debug mode. I have not added any debug messages as the crash appears when you click on a build in QT widget. That is prefilled automatically and I only react on changes.
Let me know if you see anything in the console.
 

Attachments

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Ok, here is a version of Ted compiled in debug mode. I have not added any debug messages as the crash appears when you click on a build in QT widget. That is prefilled automatically and I only react on changes.
Let me know if you see anything in the console.
Um, where should this be located/how should I start this? I can't run it directly as it needs to know the location of libQt5WebEngineWidgets.
 

dawlane

Active Member
CX Code Contributor
Joined
Jun 21, 2017
Um, where should this be located/how should I start this? I can't run it directly as it needs to know the location of libQt5WebEngineWidgets.
Rename the Ted in the bin directory and place the debug version there.
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Rename the Ted in the bin directory and place the debug version there.
I'm having a melt down (maybe hangover :D ) - I looked in /bin but couldn't see 'Ted' and never thought to use 'locate'. :oops:
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Still no output I'm afraid, but identical way to crash: Change font size and close options dialog, reopen and click fontface selector -> crash
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Actually, that isn't quite correct. The sequence required to crash is:

Open options then open 'Font Family' dropdown. Close the font selector without making any change.
Change the font size and click ok
Open options and click 'Font Family' dropdown causes immediate crash.

My guess is something isn't being re-loaded (or has been cleared/nulled) the second time that font selector is opened.

Tried redirecting output to a file just in case it's not showing in the terminal for some weird reason but no joy.

EDIT: The crash doesn't happen if I follow the same sequence but change some other option, eg 'Caret Row'
 

dawlane

Active Member
CX Code Contributor
Joined
Jun 21, 2017
Well I cannot reproduce this issue on Linux Mint 19, so I would suggest that you specify which Linux distribution, the distribution version, which version of the Qt libraries is preinstalled. You will also need to state if you are using the Mesa drivers or proprietary drivers.
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Here are the details...

- Linux Mint 18.3 Sylvia 64-bit
- QT installed version is 5.5.1+dfsg-16ubuntu7.5 (from official Mint repo)
- I'm using nVidia drivers on a GeForce GT 730 2gb card
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
I take it that's the version on Mint 19 then? I'll probably upgrade Mint in the next month or two, I don't want to install a newer version of QT in case it breaks one of the other apps I'm using. As I said before, it's not a big deal - if it continues to happen when I next upgrade I'll let you know :D
 

dawlane

Active Member
CX Code Contributor
Joined
Jun 21, 2017
The new build of Cerberus comes with Qt 5.9.2, so it shouldn't matter. As long as Ted was built against the files downloaded from the Qt Company.

Open the file qt.conf in the bin directory and add these lines:

Libraries = lib
LibraryExecutables = libexec
Translations = translations

The version of Qt that comes with Mint 19 is 5.9.5+dfsg_0ubuntu2.
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Open the file qt.conf in the bin directory and add these lines:

Libraries = lib
LibraryExecutables = libexec
Translations = translations
That doesn't make any difference I'm afraid.
 

MikeHart

Administrator
Staff member
Joined
Jun 19, 2017
Location
Germany
Open options then open 'Font Family' dropdown. Close the font selector without making any change.
Change the font size and click ok
Open options and click 'Font Family' dropdown causes immediate crash.
Nope, no crash here. Sorry :oops:
 

Paul59

Active Member
CX Code Contributor
Joined
Dec 13, 2018
Location
UK
Currently Liberation mono but it happens with any font I choose so if I choose a new font, click ok then quit CX, restart, look at font family but not change it, change size then click ok, go back to options, try to look at font family again -> crash. It's as if changing the font size after using family dropdown is causing the dropdown to fail to populate or be inadvertantly freed.
 
Top Bottom