Moving to Lubuntu 20.04 LTS 64bits... Well, almost ;)

rickychus

Member
Joined
Sep 26, 2017
Messages
36
Hello, I am here again bothering you a little more :oops:.

I tell you that recently I decided to move to 64 bits and forget the old architecture, Even if my old PC decides to explode... Anyway. Everything is going great with this distro on my old PC. Until I tried to get Cerberus X 64 bit to work. I have received several "Warning" notices, and in some cases complete crashes.
Needless to say that I install all the dependencies that the Linux section is detailed.

1 - Downloading Cerberus X 64 bits from the download section.
* When I try to compile any example in "Debug" mode, I get a few "Warning", but it runs without major problems. I attach what the console shows. In all examples the same "Warning" messages occur. Read "Cerberus Error Debug.txt".

* When I try to compile in "Release" mode, the same thing happens, but with a tragic ending. A beautiful crash of the example and "TED". I am attaching console messages and a screenshot. Read "Cerberus Error Release.txt".

ScreenShot
Screenshot (Fatal Error Release).png


2 - Try to download the source code and compile it, but with more "Warning" messages and the final result does not run "TED". I am attaching a file with the console messages. Read "Compiling Warning.txt".

I have installed this distro on two machines with the same result. Maybe it's too early to try this distro and I still have bugs?
Well, I hope it helps all the information that I leave you and I apologize if it only happens to me.
R.-
 

Attachments

  • Cerberus Error Debug.txt
    8.2 KB · Views: 22
  • Cerberus Error Release.txt
    9.1 KB · Views: 24
  • Compiling Warning.txt
    57.3 KB · Views: 24

Phil7

Administrator
CX Code Contributor
3rd Party Tool Dev
Joined
Jun 26, 2017
Messages
533
Just a first guess. Check the version of gcc. I was playing with Manjaro some time ago, having a similiar problem. I try to find the according thread with @dawlane s solution.

Here is the mentioned thread.
 

rickychus

Member
Joined
Sep 26, 2017
Messages
36
Well, everything went well... :cool:
Indeed, the gcc g++ 9.XX was active by default (XX = I don't remember how it ended :rolleyes:, which implies that I will not be able to remove it, that happens to me in a hurry and not take notes :confused:).
I followed the guide that you suggested and everything was solved. The gcc g++ version 10.2.0 remains active, and Cerberus X compiles without any problems.
Here are the commands I use to install and correct the problem in case someone needs it.

Code:
sudo apt-get install gcc-10 g++-10

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-10 10
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-10 10

sudo update-alternatives --set cc /usr/bin/gcc
sudo update-alternatives --install /usr/bin/cc cc /usr/bin/gcc 30

sudo update-alternatives --set c++ /usr/bin/g++
sudo update-alternatives --install /usr/bin/c++ c++ /usr/bin/g++ 30

sudo update-alternatives --config gcc
sudo update-alternatives --config g++

Thank you very much as always and stay as vibrant as ever.
Kind regards R.


PS: I have noticed a considerable improvement in CPU usage. Maybe it is due to the change of architecture, use of the new Vulkan API, or graphical optimization of Cerberus X? The blobmonster example on the older Linux 32bits consumed 40% of the CPU. Now only 9% constant use on the same computer. That's great!
 
Last edited:

rickychus

Member
Joined
Sep 26, 2017
Messages
36
Hello, me again...
I had problems again compiling into CerberusX under Lubuntu 20.04 x64. The change and solution of the compiler to version 10, did not last long ... Surely in an update of Ubuntu 20 something must have changed since CerberusX began to give problems again when compiling its applications.
I had to go down to version 7. It is the same that is used in Ubuntu 18.04. No problems so far.
To downgrade, you just have to change the command 10 to 7, and finally choose the compiler in version 7.

Code:
sudo apt-get install gcc-7 g++-7

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-7 10
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-7 10

sudo update-alternatives --set cc /usr/bin/gcc
sudo update-alternatives --install /usr/bin/cc cc /usr/bin/gcc 30

sudo update-alternatives --set c++ /usr/bin/g++
sudo update-alternatives --install /usr/bin/c++ c++ /usr/bin/g++ 30

sudo update-alternatives --config gcc        <-- Here choose the compiler option 7.5
sudo update-alternatives --config g++        <-- Here choose the compiler option 7.5

Everything is fine using version 7.5 of the compiler.
R.-
 
Top Bottom